www.imoc.co.uk Forum Index
 AlbumAlbum CalendarCalendar FAQFAQ SearchSearch MemberlistMemberlist Legal NoticeLegal Notice IMOC 1/4 Mile1/4 Mile Table Knowledge BaseKnowledge Base   RegisterRegister 
 GarageCommittee GarageGarage  SubscriptionPremium Membership  ProfileProfile   Log in to check private messagesLog in to check private messages   Log inLog in 
Calendar 
Knowledge Base 
 How to solve hesitation, missfires and flat spots 
Description Steps to solve these problems
Author Goldy Date Fri Nov 25, 2005 12:17 pm Type Text How-To

Category Engine
Viewer Comments [8 - Post your comments]
Views 31285
How to solve hesitation, missfires and flat spots
Steps to solve these problems
This comes up a lot so I thought I would do a little write up on it. Feel free to add to this if you feel I have missed something out!

Hesitation and flat spots are generally caused by poor ignition components. I have recomended things to check in the order that they are likelyest to be and the cost of replacement.

1. Check the distributer cap and rotor arm. (see separate how to for replacing them) If the contacts are heavily corroded or damaged replace them. Check for signs of oil or water in the distributer cap. Whilst you have the cap off.....

2. Check the state of the connectors on the HT leads, look for corrosion or damage to the contacts again.

3. Check the state of the ht leads in general, look for splits in the leads, kinks and check the connectors at the spark plug ends.... whilst you have the ht leads out.....

4. Check the state of the sparkplugs.... look for wear on the electrodes, damage or discolouration

5. Check the airfilter.... replace / clean if dirty

6. Check the ecu for error codes and perform an ecu reset.

If these all look ok but you still have a flat spot I suggest:

1. Replace the dizzy cap and rotor arm first (around '20 for the pair from mrT)

2. Replace the sparkplugs next (NGK's cost about '8 for 4 from unipart)

3. If the problem is still there try some injector cleaner

4. I suggest changing HT leads last of all as these don't tend to fail very often and are very expensive to replace!
  

 User comments 
Wathall: Sat Mar 21, 2015 7:18 pm    

What was the vacum leak ?
monstr2: Mon Mar 26, 2018 3:23 am    

Tighten the intercooler pipe couplers really really hard as i just found that was the reason my car would not go more than 80 kmph in 2nd gear.

Also replace all the vaccum hoses if they are old as that solved my heat soak problems!
chrisE: Fri Apr 12, 2019 2:56 pm    

Better late than never:

Check your ignition module, coil, and the mounting bracket that these are attached to. Due to their position in the engine bay, they're exposed to a large amount of water falling from the engine lid and boot lid.

Remove and check the Ignition Module to ensure it appears in good condition with no corrosion within its connector. Replace after 10 years.

The Ignition Coil is prone to crack so I'd recommend this is replaced at least every 5 years, costs around £50. Also bear in mind that this uses a ground connection via the bracket it attaches to, so the bracket should be clean and free from any rust or corrosion where the coil sits. The mounting screws usually rust quite badly so replace with 4 M4x30mm stainless steel screws (not zinc-plated ones).

This link shows a photo of a brand new Ignition Module and Ignition Coil.
https://photos.app.goo.gl/JyavkS8Y7rjf6EPr9


The HT wires and spark plug holes are exposed to rainwater during heavy rainfall, even if the standard engine lid is fitted with the rain tray. I have a TRD strut brace which I plan to use to fit a sheet of aluminium to cover the T/B, HT wires, distributor, etc.

The electrodes within the distributor caps tend to get some corrosion between the edge where the rotor makes the electrical connection. Make sure you replace the rubber distributor cap seal when replacing the cap and use some silicone lubricant around the edge of the seal after fitting.

The distributors themselves tend to leak oil after many years. You can remove the distributor and replace the oil seal o-rings which is cheap to do.

The genuine Toyota HT ignition wires are pretty reliable - I've had mine fitted for 10 years. The life of these can be extended by spraying silicone lubricant onto them. That said, they should probably be replaced after 15 years as rubber doesn't last forever.. but new genuine Toyota HT wires can cost over £100 depending on engine model.


Edit: here's the 3S-GTE service specs from the MR2 BGB (service manual)

You can test each HT wires' resistance using a multimeter. It should not read above 25,000 ohms.

The primary Ignition coil resistance (while cold) should be 0.36 - 0.55 ohms.
Secondary Ignition coil resistance (while cold) should be 9,000 - 15,400 ohms.

Spark plugs should always be gapped at 0.8mm and tightened to 18 Nm / 180 kgf cm / 13 ft lbf. Use copper NGK BKR6E plugs

When checking/adjusting ignition timing (with TE1 & E1 diagnostic terminals connected), this should be 10 degrees BTDC at idle.


Also, or if your car is modified with increased boost us one grade colder plugs, eg. BKR7E. Copper plugs have better conductivity than platinum plugs, and I recommend these are replaced at least every 8000 miles, or 4000 miles if the car is modified.


Regards

Chris
Page 2 of 2 All times are GMT
Goto page Previous  1, 2 
Viewer Comments [8 - Post your comments]

Jump to:  

Powered by Knowledge Base, wGEric © 2002 PHPBB.com MOD
This script (Knowledge Base - MX Addon v. 1.03e) is modified by Haplo



Powered by phpBB © 2001, 2005 phpBB Group