www.imoc.co.uk Forum Index
 AlbumAlbum CalendarCalendar FAQFAQ SearchSearch MemberlistMemberlist Legal NoticeLegal Notice IMOC 1/4 Mile1/4 Mile Table Knowledge BaseKnowledge Base   RegisterRegister 
 GarageCommittee GarageGarage  SubscriptionPremium Membership  ProfileProfile   Log in to check private messagesLog in to check private messages   Log inLog in 
Calendar 
[Mk2] [NA] Need advice: Is my timing off?

 
Post new topic   Reply to topic       www.imoc.co.uk Forum Index -> MR2 MK2 1990 - 1999 NA & Turbo -> Mechanical
View previous topic :: View next topic  
Author Message
Masacur




Joined: 19 Sep 2011
Posts: 55
Location: Belgium
Feedback Score: 1



PostPosted: Sat Jun 24, 2017 2:58 pm    Post subject: [Mk2] [NA] Need advice: Is my timing off? Reply with quote Reply with quote including images

Hi,

I am hoping to gain some advice about what might be the issue with my SW20. It is a 1992 Rev2 converted with Rev3 engine.

    - Upon accelerating, the car starts to hesitate and hold power. Becomes worse on higher gears.
    - If you drive at constant speed between 2000-4000 rpm and give additional throttle, it starts to go but after 0.2-0.5 sec it looks like it is hitting rpm limiter.
    - Above 5500 rpm it feels normal and pulls hard.
    - I think it misfires because when idling I hear little explosions from the exhaust once per 2 second or so


I am thinking about a timing issue but I am not really experienced with diagnosing problems.

I hope you are able to judge from the video what could be issue.

Thank you!

https://youtu.be/ic33x9YCSuk
Back to top
User is offline 
Bear87
Premium Member



Joined: 28 Sep 2016
Posts: 224
Location: Essex
Feedback Score: 1

1992 Toyota MR2 Mk2 Turbo Rev2

PostPosted: Sat Jun 24, 2017 4:53 pm    Post subject: Reply with quote Reply with quote including images

I would start with your ignition system. Mr2s are known to have issues like yours. Check your dizzy cap, rotor arm, ht leads, plugs and possibly the coil.

They are also known for leaking capacitors on the ecu. Just pull the ecu cover and see if any caps are leaking it can cause similar symptoms.

Timing is also a possibility but i would start with the easy/most likely causes.

Hope that helps [thumleft]
_________________
Smoke me a kipper. I'll be back for breakfast.
1992 Rev 2 Turbo Super Red
1991 Rev 1 N/A Steel Mist Grey (daily)
Back to top
User is offline 
Masacur




Joined: 19 Sep 2011
Posts: 55
Location: Belgium
Feedback Score: 1



PostPosted: Sun Jul 02, 2017 9:07 pm    Post subject: Reply with quote Reply with quote including images

Thanks for the reply.

The previous owner washed the engine bay and the spark plug holes/cylinders where full of water. I cleaned them out and it is running perfect again.
Back to top
User is offline 
Display posts from previous:   
Post new topic   Reply to topic       www.imoc.co.uk Forum Index -> MR2 MK2 1990 - 1999 NA & Turbo -> Mechanical All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group