www.imoc.co.uk Forum Index
 AlbumAlbum CalendarCalendar FAQFAQ SearchSearch MemberlistMemberlist Legal NoticeLegal Notice IMOC 1/4 Mile1/4 Mile Table Knowledge BaseKnowledge Base   RegisterRegister 
 GarageCommittee GarageGarage  SubscriptionPremium Membership  ProfileProfile   Log in to check private messagesLog in to check private messages   Log inLog in 
Calendar 
[Mk2] [Turbo] Issue Gen 2 3sgte medium boost destroying turbos

 
Post new topic   Reply to topic       www.imoc.co.uk Forum Index -> MR2 MK2 1990 - 1999 NA & Turbo -> Modifications
View previous topic :: View next topic  
Author Message
gips




Joined: 04 May 2010
Posts: 14

Feedback Score: 2



PostPosted: Thu Mar 23, 2017 1:57 pm    Post subject: [Mk2] [Turbo] Issue Gen 2 3sgte medium boost destroying turbos Reply with quote Reply with quote including images

Hello all,
im having trouble with recently increased boost on my car. Was using a Ct26 in perfect condition for around 2 years, boost was regulated by wastegate, so it was going around 0.8bar. After a while due to maf issues , when cold(leaning out in low rpm even after adjusting the idle screw) i decided to go with aftermarket ECU and increased boost. Problem was that as soon as i upped the boost to ~1bar and drove for like 30KM the turbo blew totally by bending the shaft and destroying the impellers. It was not possible to rebuild, so i went a CT20B. Everywhere i read they say you can boost this one safely at 19PSI. So there i went 19PSI. Problem is after like 2000km the turbo axial play increased a lot, it started smoking and it ended up also having a lot of radial play leading to a rebuild with replacing the compressor wheel as the old one was touching the housing and was damaged. After disassembly the rebuild company found a very small particle of silicone like 0.5mmx0.5mm on the nozzle of the axial bearing, so we decided that was the actual issue not the boost. There i go new rebuilt turbo, boosting again 19 psi and after 1000KM problem, it started smoking again. I checked it and there is a lot of axial play , no radial play at all, but it seems the axial is big enough for the turbo to smoke. Im for a rebuild again, but the question is, what is going wrong, are the CT20B incapable of producing safely 1.25bar ? Im not using a highly modified engine. Gen2 head, cams are stock from N/A and a 3inch freeflow exhaust. That is pretty much it. Any suggestions are appreciated.
Back to top
User is offline 
jimGTS
Premium Member



Joined: 14 Dec 2004
Posts: 13946
Location: North Kent
Feedback Score: 35

1997 Toyota MR2 Mk2 Turbo Rev4

PostPosted: Thu Mar 23, 2017 3:44 pm    Post subject: Reply with quote Reply with quote including images

too much heat?? timing advanced too much?

i had a 20b up to close to 19psi (17/1[Cool] for a good 5-10k miles, no play what so ever and no smoke. this one was a standard untouched who knows how many miles turbo.

what quality of rebuilt parts are being used?
how is the oil feed? perhaps not enough oil getting to parts, so creating heat and damaging parts.

just a few ideas
Back to top
User is offline 
androo007
Premium Member



Joined: 03 Mar 2014
Posts: 2050

Feedback Score: 9

1994 Toyota MR2 Mk2 Turbo Rev3

PostPosted: Thu Mar 23, 2017 7:09 pm    Post subject: Reply with quote Reply with quote including images

So you're running an ecu for a rev 2 specifically but with rev 3 running gear? I'd check afrs
Back to top
User is offline 
gips




Joined: 04 May 2010
Posts: 14

Feedback Score: 2



PostPosted: Mon Mar 27, 2017 8:42 pm    Post subject: Reply with quote Reply with quote including images

Build parts, i have no idea, but i will take a look , when its apart. Verified the oil feed, it seems more than enough oil is reaching the turbo. The turbo is now off the car and look serviceable, so i will probably try once more with another rebuild.
Back to top
User is offline 
Display posts from previous:   
Post new topic   Reply to topic       www.imoc.co.uk Forum Index -> MR2 MK2 1990 - 1999 NA & Turbo -> Modifications All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group