www.imoc.co.uk Forum Index
 AlbumAlbum CalendarCalendar FAQFAQ SearchSearch MemberlistMemberlist Legal NoticeLegal Notice IMOC 1/4 Mile1/4 Mile Table Knowledge BaseKnowledge Base   RegisterRegister 
 GarageCommittee GarageGarage  SubscriptionPremium Membership  ProfileProfile   Log in to check private messagesLog in to check private messages   Log inLog in 
Calendar 
[Mk2] [Turbo] Engine fan light

 
Post new topic   Reply to topic       www.imoc.co.uk Forum Index -> MR2 MK2 1990 - 1999 NA & Turbo -> Electrical
View previous topic :: View next topic  
Author Message
markstevieandmads




Joined: 05 Aug 2013
Posts: 1725
Location: Swindon, Wilts
Feedback Score: 4

1993 Toyota MR2 Mk2 Turbo Rev2

PostPosted: Sun Jun 05, 2016 5:49 pm    Post subject: [Mk2] [Turbo] Engine fan light Reply with quote Reply with quote including images

I've decided to run my intercooler fan full time by unplugging the sensor on the engine lid.

I've tapped the sensor and the unused wiring out of the way and the wiring is all insulated.

However occasionally I'm getting the engine fan light come on. The fan is still running on the intercooler and the fans work correctly and do not overheat on the normal rad.
If I turn ignition off and back on again it clears the light and it doesn't appear again . However it can appear at anytime randomly though everything seems to work as it should.

Apart from removing the bulb which is only hiding it, what else could be causing this?
Surerly if it was the unplugged connector then it would do it all the time?
Back to top
User is offline 
kungfucop




Joined: 07 Sep 2017
Posts: 5
Location: Canada
Feedback Score: 0



PostPosted: Sat Sep 09, 2017 8:24 pm    Post subject: Reply with quote Reply with quote including images

Check your intercooler fan fuse. The 20A marked "VENT" in the engine fuse box. And also check the wiring harness / connector that actually plugs into the IC fan. Make sure it isn't flopping around and accidentally touching the exhaust manifold heat shield.
Back to top
User is offline 
mr2magic




Joined: 09 Apr 2010
Posts: 618
Location: Hannover, Germany
Feedback Score: 1

1991 Toyota MR2 Mk2 Turbo Rev1

PostPosted: Wed Sep 13, 2017 5:21 pm    Post subject: Reply with quote Reply with quote including images

Also check the fan ecu. The black box in the boot to the right of the ecu. I took mine apart, cleaned everything and put it back - no more light
Back to top
User is offline 
Display posts from previous:   
Post new topic   Reply to topic       www.imoc.co.uk Forum Index -> MR2 MK2 1990 - 1999 NA & Turbo -> Electrical All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group