www.imoc.co.uk Forum Index
 AlbumAlbum CalendarCalendar FAQFAQ SearchSearch MemberlistMemberlist Legal NoticeLegal Notice IMOC 1/4 Mile1/4 Mile Table Knowledge BaseKnowledge Base   RegisterRegister 
 GarageCommittee GarageGarage  SubscriptionPremium Membership  ProfileProfile   Log in to check private messagesLog in to check private messages   Log inLog in 
Calendar 
[Mk2] [Turbo] Advice/Experience wanted - Rev 2--> 3 Swap won't idle / poor idle

 
Post new topic   Reply to topic       www.imoc.co.uk Forum Index -> MR2 MK2 1990 - 1999 NA & Turbo -> Mechanical
View previous topic :: View next topic  
Author Message
Danbob




Joined: 14 Nov 2011
Posts: 780
Location: Wellingborough
Feedback Score: 12

1993 Toyota MR2 Mk2 Turbo Rev2

PostPosted: Fri Nov 25, 2016 9:41 pm    Post subject: [Mk2] [Turbo] Advice/Experience wanted - Rev 2--> 3 Swap won't idle / poor idle Reply with quote Reply with quote including images

My engine is all back together and has done 500 miles of running in, but still won't idle right. Would like to hear other peoples experiences especially where a solution has been found.

Background
ST205 head
Rev 3 Turbo harness
ST205 ECU
HKS 264 cams
CT27 turbo

Running sweetly through rev range, only has a problem at idle.

will idle at 1000k no problem using throttle, but will not control idle by itself.
needs a dab of throttle to start up, happier idling cold than warm


Will hunt between 400rpm and 900rpm continuously, stalls if you come to a stop when engine warm and when clutch or brake pressed, anything that upsets the delicate idle.


Have checked and confirmed that TPS is set correctly.
Confirmed throttle plate set screw is set correctly
Checked for major vac leaks (of course could be some hiding)

Would make sense to remove IAC and clean/test that, but I'm suspicious that it's more likely to be something electrical

Anybody else had this with a gen 2 --> 3 swap?
Anybody experienced similar symptoms and found a fix?


Cheers
Dan
Back to top
User is offline 
pbmr2
Premium Member



Joined: 18 Jun 2010
Posts: 743

Feedback Score: 10



PostPosted: Fri Nov 25, 2016 11:42 pm    Post subject: Reply with quote Reply with quote including images

hunting is a classic air leak. had this myself, turned out to be a leak on the idle control valve where it had cracked.

seen it a number of times and it's alway a combo of idle valve any/or intake side air leak.

Not had it on a swap as not done that swap, but have seen it on ren 1, 3 and 3.
pocket money on an air leak. if that leak is caused by the idle valve or the valve being gummed up plus trying to compensate for an air leak, not sure.
Back to top
User is offline 
Danbob




Joined: 14 Nov 2011
Posts: 780
Location: Wellingborough
Feedback Score: 12

1993 Toyota MR2 Mk2 Turbo Rev2

PostPosted: Sat Nov 26, 2016 9:16 am    Post subject: Reply with quote Reply with quote including images

Yeah that does make sense, I hate searching for vac leaks, guess I'm my head I've been trying to put it off.

Will break out the boost leak tester and rule that out first!

Cheers
Back to top
User is offline 
killerferret666
Premium Member



Joined: 26 Jul 2012
Posts: 595

Feedback Score: 4



PostPosted: Mon Aug 21, 2017 7:20 am    Post subject: Reply with quote Reply with quote including images

Got exactly this after a swap, so at least I know what to look for now.

DanBob did you find the problem?
_________________
My Blog on Miami GT4 kit car build using MR2 Donor Car

http://miamigt4kitcar.blogspot.co.uk/

twitter for photo's as I'm building -
www.twitter.com/iwanabeaferret
Back to top
User is offline 
Display posts from previous:   
Post new topic   Reply to topic       www.imoc.co.uk Forum Index -> MR2 MK2 1990 - 1999 NA & Turbo -> Mechanical All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group